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1. Introduction 
This document introduces you to the Excel spreadsheet. It outlines the general 
structure of spreadsheets, then tells you specifically how to use Excel 2007.  

Files produced in Excel 2007 have the file extension ".xlsx", and the files themselves 
are very different from previous file formats. If you wish to use an old Excel 
spreadsheet in Excel 2007, Excel will switch to compatibility mode, to let you work 
on the old file with no problems. You can then save this file in Excel 97-2003 format, 
or you can save it in the new Excel 2007 format. 

If you give a copy of a new Excel file to a colleague who is using an older version, 
they will not be able to read it initially. However, their Excel will detect this new 
format, and will invite them to download and install a compatibility pack. Once they 
have done this they will be able to work on Excel 2007 files in their older version. 

 
2. Overview of Spreadsheets 

A spreadsheet is a numerical tool that is easy to use but deceptively powerful. It 
revolves around collections of worksheets, each of which consists of rows labelled 
numerically, and columns labelled alphabetically. At each intersection of a row and a 
column is a cell, referred to by its position, A3, B1 C265, etc. 

 

Into these cells you type data, and then operate on these numbers by adding functions. 
These might produce running totals of columns, multiply numbers in adjacent rows 
together, or do any kind of numerical operation. The clever part happens when you 
change the data, however, because spreadsheets work dynamically. This means that 
totals, or results of calculations, are updated automatically when any relevant number 
in the worksheet changes. 

An obvious example of the use of a spreadsheet is a bank statement. This contains a 
description of transactions in one column, credits in another column, and debits in the 
third column. At the top of the sheet is the previous balance and at the bottom is the 
new balance, which is worked out as 

new balance = previous balance -total debits + total credits 

Following on from this, business balance sheets are another popular example of 
spreadsheets at work.  

On a more imaginative level though, spreadsheets can be used to record scientific 
measurements and dynamically calculate the parameter of interest, and at Corporate 
Information and Computing Services a spreadsheet is used to record course bookings 
and attendance in order to forecast demand for the next session. 
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3. Getting Started 

3.1 Starting Excel 2007 

To use Excel you first need to start up your computer and log on with your usual 
username and password. Click the Start button and select All Programs, then from 
the sub-menu, select Microsoft Office, then select Microsoft Office Excel 2007. 
When Excel loads you will see the following screen. 

 

The Workbook 

You will notice that the title bar is labelled Book1 - Microsoft Excel. Excel handles 
workbooks, which are collections of worksheets. You will also notice that below the 
displayed cells there are a series of tags labelled Sheet1, Sheet2, and Sheet3. By 
clicking on a tag with the mouse you will display the contents of that particular 
worksheet. 

You can use the workbook structure of Excel to store related tables together, but 
without cluttering a single sheet. 
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4. The User Interface 
The user interface is very different to previous versions of Excel. Once you get used 
to it, it becomes very easy to use. Microsoft has created online training modules that 
tell you how to find familiar commands in the new interface. You can access these 
modules from www.shef.ac.uk/cics/office2007 where you will also find a detailed 
CiCS guide to the new interface. 

4.1 The Office Button 

In the top-left corner of the new interface you will find the Office button, 
which replaces the File menu from previous versions of Excel. Click this 
button to reveal options allowing you to Save and Print files. It contains a 

list of your most recently accessed spreadsheets, and it contains the Excel Options 
button, which take you to options previously found in the Tools menu under 
Preferences. 

4.2 The Quick Access Toolbar 

Situated to the right of the Office button, the Quick 
Access toolbar holds buttons that can be accessed from 
all views of Excel. Whatever you are currently doing, 

you will be able to access these commands. Initially, the toolbar contains a Save 
button and Undo and Redo buttons, but you can easily customise the Quick Access 
Toolbar to hold your favourite commands. 

4.3 The Ribbon 

 

The ribbon contains eight tabs, each relating to a specific task. 

Each tab contains several groups of tools; here the Clipboard, Font, Alignment and 
Number groups are visible. 

Each group contains related buttons, menus and lists. 

 Some groups have an arrow in the bottom right corner, which gives a dialog box 
when clicked. 
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5. Using Excel 

5.1 Selecting Cells 

If you click on a cell with the mouse you will see its name appear on the left hand 
side of the formula bar. As you click on different cells the name in the formula bar 
will change accordingly. Alternatively, you can select different cells in the worksheet 
using the arrow keys or the Enter and Backspace keys. 

You can select a range of cells by clicking on a single cell at one corner of the range 
then, with the mouse button held down, drag the selection so that it extends over the 
other cells. To select an entire row of cells you can click on the row number, and you 
can select columns by clicking on the appropriate letter. Finally, you can select the 
entire worksheet by clicking on the grey box against the letter A and number 1. 

5.2 Changing to a New Worksheet 

If you want to include some related data, but don’t want to overload your current 
worksheet you can begin a new sheet. To do this click on any of the tags below the 
cells to display the corresponding sheet. 

To make individual sheets of data easily recognisable you can name each sheet that 
you use. To name the current sheet double click the sheet label (Sheet1, Sheet2 etc) 
to select it, then enter a new name for that worksheet and press Enter. If you need 
more than three worksheets, go to the Cells group on the Home tab and click the 
Insert button. From the menu select Insert Sheet.  

5.3 Entering Data 

To enter data into a cell first select the cell. As you start to type you will notice that 
buttons materialise in the formula bar and that the data appears simultaneously in the 
formula bar and in the selected cell. 

 

Having typed the data for that cell you can then press the Enter key or click on the 
tick button. The formula bar will then clear leaving only the cell reference displayed. 

If you need to edit the contents of a cell you can do this via the formula bar. First 
click on the cell in question so that its contents appear in the formula bar. Then click 
within the formula bar to produce a cursor with which to edit the cell contents. 
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5.4 Formatting Text 

A worksheet containing raw data is not very clear, but you can improve its 
appearance by applying different formats to some key cells. The most popular 
formats are available through tools in the Font and Alignment groups on the Home 
tab. 

 

The button in the lower-right corner is very useful for headings. If you select a single 
cell, then extend the selection horizontally across adjacent cells you can then click on 
this button to centre the single cell contents across the selected range. 

Finally, you can adjust the width of any column by positioning the cursor between 
two lettered column headings and dragging the column wider. To automatically adjust 
any column to accommodate its widest entry, simply double click the column label. 
Row heights can be adjusted in a similar way.  

5.5 Formatting Text Using Styles 

Excel 2007 offers a more powerful way to quickly format text, using the tools in the 
Styles group on the Home tab. Select one or more cells, then from the Styles group, 
click the Cell Styles button. 

 

5.6 Formatting Tables 

Alternatively, you can select all of your data, or a self-contained subset, and format 
the entire selection as a table. 

Select your data, then from the Styles group on the Home tab, click the Format as 
Table button. You will see a large choice of coloured table formats, choose and 
format to apply to your selected data. 
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5.7 Formatting Numbers 

To clarify your worksheet further you can specify the format in which selected 
numbers are displayed. To do this, select the cells containing the numbers in question, 
then from the Number group on the Home tab, click the drop down list. 

Select any numbering style, or for more options, select the More Number Formats 
option. In the dialog box that appears, you will see a list of categories of numbers and 
for each category there will be a second list containing possible formats. You can 
then choose a format for your selected data. 

 

In addition, there are buttons in the Number group which will quickly format 
numbers as currency, percentages, or fixed numbers of decimals.  

5.8 Formatting Dates 

If you choose the date format for numbers, you have a great deal of control over how 
your dates appear in the worksheet. If you select Date from the dialog box above you 
will be offered a choice of formats, but you can create your own format by clicking 
the Custom option. You can then build a date format using the letters d, m and y for 
date month and year as follows 

dd two digit day number 01, 02, … 31 
ddd three letter day Mon, Tue, … Sun 
dddd full day name Monday Tuesday, … Sunday 
mm two digit month number 01, 02, …12 
mmm three letter month name Jan, Feb, … Dec 
mmmm full month name January, February, … December 
yy two digit year 98, 99, 00, … 
yyyy four digit year 1998, 1999, 2000, … 

So the date format dddd dd-mmm-yy would give dates in the form: 

Monday 06-Mar-00 
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6. Working with Files 
Read section 1 to find out about working with the new file formats. 

6.1 Saving Files 

As you type data from the keyboard it will appear on your screen and you can watch 
as your workbook grows.  To make your work safe you need to make a secure copy 
of your workbook in a file.  

To save your file, either click the Office button and select Save, or click the save 
button in the quick access toolbar. The first time you do this for a particular file you 
will get a dialog box where you can supply a name for your workbook, and specify a 
place in which to save it. 

 

Specify a name for the file in the File Name box. A file name can contain up to 256 
characters, including spaces and capital letters. Next you need to specify the location 
for the file. This can be any folder on your hard disk or network account. Initially, 
Excel will offer you the My Documents folder but you can change this by selecting a 
new drive or folder from the Save in menu. 

The file name is followed by the extension .xlsx The name helps you identify 
individual files whereas the extension helps Excel to recognise files that it has been 
used to create. When you have entered a name, click the Save button to save it. All 
subsequent saves will update the existing file without asking for a filename. 

6.2 Closing Files 

If you have finished working on a workbook for the time being, but want to carry on 
using Excel to edit a different workbook, you should save your work as described 
above, then click the Office button and select Close from the menu, or click the close 
button in the workbook window. This will close the workbook down but will still 
keep Excel running. You can then begin work on your second workbook. 
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6.3 Opening Existing Files 

When you want to continue work on a workbook that you started earlier you should 
click the Office button and select your file from the list in the right column of the 
menu. If your file is not listed, click Open to see the following dialog box. 

 

You can then select a file from the list, or use the Look in menu to access files on 
different drives, or use the History button to list your most recently used Excel files. 
When you have your file selected click on the Open button to load it into Excel. 

6.4 Creating a New File 

When you want to start a new workbook click the Office button and select New from 
the menu. This will give you a new screen with a blank workbook area.  

6.5 Exiting from Excel 

When you have finished all your work for the time being, and all your workbooks 
have been saved, you can leave Excel altogether by clicking the Office button and 
clicking the Exit Excel button. Alternatively, you can simply click the Close button in 
the Excel Title bar. 

All your workbooks will close one by one and you will be prompted to save any 
workbooks that have changed. Finally Excel itself will close down leaving you at the 
Desktop. 
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7. Spreadsheet Tools 
Typing and formatting data is all well and good but the purpose of a spreadsheet is to 
process your data. In this section we will introduce you to some powerful features 
found in Excel.  

7.1 Simple Formulae 

One way to process a set of numbers in your worksheet is to use a formula. Simply 
click on the cell in which you want the result to be displayed, then type in your 
formula. It should begin with the equals sign (=) and may contain cell references, 
numerical constants, or pre-defined Excel functions. 

For example, to add the contents of cells A2, A3, A4 and A5 and put the result in A6 
you would type the following formula into cell A6 

=A2+A3+A4+A5 

Whilst you are typing it in the cell displays the actual formula, but as soon as you 
press the Enter key the contents of the cell change to show the result of the operation. 

When building formulae you use the following symbols 

=A1+A2 add contents of cell A1 to contents of cell A2 

=A1-A2 subtract contents of cell A2 from contents of cell A1 

=A1*A2 multiply contents of cell A1 with contents of cell A2 

=A1/A2 divide contents of cell A1 by contents of cell A2 

All formulae and functions in a worksheet process the contents of specified cells. If 
you decide to change the contents of a significant cell, then all formulae that refer to 
that cell respond immediately and automatically update their displayed result. This 
makes the spreadsheet an incredibly powerful tool, indispensable for answering 
‘What would happen if...’ type questions. 

7.2 Summing Numbers 

To add a large range of numbers you can use the Excel SUM function as follows: 

=SUM(A2:A5) 

However, rather than typing this in, you can go to the Formulas tab, then in the 
Function Library group, click the AutoSum button. Excel will place a dotted line 
round the numbers that it thinks you want to add. If Excel’s guess is correct you can 
then simply click the AutoSum button again, or press the Enter key to confirm the 
range and accept the formula. If Excel guesses wrongly, however, you can simply 
select the correct range with the mouse and press the Enter key. When you are 
confident with AutoSum you can speed up the process by double-clicking the button. 

In addition, every time you select an area of numbers, Excel will display the sum in 
the status bar at the bottom of the Excel screen. 
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7.3 Other Excel Functions 

To access other simple Excel functions, click the arrow next to the AutoSum button. 
You will see a menu of simple functions for you to use. 

If you wish to use Excel’s powerful functions, click any category in the Function 
Library group. This will produce a long list of functions. When you select any 
function, you will be asked to specify a range of values, the screenshot below uses the 
example of the Asinh function. 

 

Here you can click the  button to shrink the dialog box:  

 

And you can easily select the required range of cells without the dialog box cluttering 
the screen. 

7.4 Data-Fill 

Entering data into a worksheet can be a laborious process. Excel can help you with 
this by making intelligent guesses as to what you intend to type in. So if you type the 
word ‘Monday’ in cell B2, for example, Excel can automatically insert Tuesday to 
Friday into cells B3-B6. The process by which Excel does this is called data-fill. 

To use data-fill you first need to select a few cells at the beginning of a sequence. On 
the corner of the border of the selected cells you will notice a little box. This is called 
a data-fill handle. If you position the cursor above this it turns from white to black. 

To extend the selected sequence you should click and hold down on the data-fill 
handle, then drag the border over the adjacent cells. When you release the mouse 
button, all the selected cells will be filled in according to the sequence. 

A more powerful incarnation of this feature is the automatic generation of formulae. 
If you have, for example, five columns of numbers and you want to sum each column, 
you can simply AutoSum the first column, then use data-fill to drag the formula 
across the other four columns. If column one has the sum of cells A1 to A6, then 
column two would automatically perform the sum of B1 to B6 etc.  
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8. Data Validation 
When you specify the type of data allowed in a cell you could also specify an allowed 
range of data. If a user then attempts to input invalid data into the cell Excel can 
display a message from you to correct them. Excel can also check the entire 
worksheet for invalid data. To use this feature, go to the Data tab, and in the Data 
Tools group, click the Data Validation button. 

 

Initially cells will allow any value to be input. To change this use the Allow list to 
specify the type of number (integer, decimal, etc) and use the Data list to specify a 
range. New fields will appear in the dialog, and you can enter maximum and 
minimum values. You can then use the Input Message and Error Alert tabs to 
provide helpful messages to people entering data. 

You can also specify normal ranges of data so that any values falling outside this 
range can be automatically formatted to bring attention to them. To use this feature 
select the cells in question, then go to the Data tab and in the Styles group, click 
Conditional Formatting. From the menu, select Highlight Cells Rules. 

Click the option that will best help you describe the range 
of values which you are interested in. Here Between has 
been selected: 

 

Specify the limiting values in the left-hand fields, and in 
the right-hand menu, specify the distinctive formatting 
that you wish to use for any cells that meet the criteria. 

Click OK to return to your worksheet. 
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9. Restructuring Your Workbook 
As your worksheet develops you may find that your original layout is not as well 
thought out as it could be, and you might need to make some more space somewhere. 

9.1 Dragging Cells 

Excel offers you many ways to reposition cells, but none more elegant than dragging 
a selected range to a new location, leaving Excel to deal with the relative cell 
referencing. 

To drag a range of cells, you first select a group by dragging with the mouse. Then 
you position the cursor on the border of the selection. If you now click and drag this 
selection you will see a ghostly border travel around with the mouse. When you have 
this in the best position simply release the mouse button and the range of cells will 
move as indicated. 

 

To drag selected cells to a different sheet, hold down the Alt key and drag the selected 
area onto the sheet label. Excel will then display that sheet and you can position your 
selected cells as normal. 

Using this technique you can restructure your spreadsheet at any stage in its 
development. 

9.2 Cut, Copy, and Paste 

A more powerful method is to use the Windows clipboard. This is a temporary 
storage area that holds data as you move it around. You can transfer data to and from 
the clipboard using the Cut, Copy, and Paste commands, found in the Clipboard 
group on the Home tab. 

You can copy a range of cells as follows: 

1. Select the range. 

2. Copy the range to the clipboard. 

3. Click on the cell that will be the top left corner of the range in its new location. 

4. Paste the range back from the clipboard. 

The range will then be copied from the clipboard to this new location. If you want to 
move a selection rather than copy it, you use the Cut command rather than the Copy 
command in step 2. 



Bob Booth Introduction to Excel 2007 

 15  

The clipboard can hold up to twelve items at once. 
So to perform radical restructuring of your 
workbook select the first item and click the Copy 
button, then select the next items and click Copy. 
To view the collected items in your 
clipboard, click the arrow in the bottom-right 
corner of the group. The clipboard pane will open, 
displaying its contents.  

To paste any of the clipboard items into your 
document, select the desired cell in your 
spreadsheet, then click the entry that you wish to 
use and it will be pasted into the sheet. 

# 

 

 

 

9.3 Non-Scrolling Headings 

Often you will have a large worksheet with many, many rows that span several 
screenfuls. It then becomes annoying, when you are working at the lower end of the 
sheet, and it is not obvious which column is which. In this case you have to keep 
scrolling to the top of the sheet just to confirm that you are working in the correct 
column. 

To help with this, Excel allows you to freeze part of your screen, and ensure that the 
frozen part of the screen always remains visible. So you can scroll down to the 
bottom of your worksheet, whilst still being able to see your column headings. 

To do this, select the bottom row of your column headings, then from the View tab, in 
the Window group, click the Freeze Panes button, then from the menu select 
Freeze Panes. Now, when you scroll down your worksheet, all rows above the 
selected row will remain on screen, whilst the rows below your selected row will 
scroll as normal. You can return to normal scrolling behaviour at any time by 
selecting Unfreeze Panes from the Freeze Panes button in the Window group on 
the View tab. 

You can also freeze row headings in the same way by selecting any column and 
freezing the pane. 
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10. Graphs and Charts 
Having built your worksheet, you should have generated some meaningful results. 
The best way to display these results is use Excel’s powerful graphing facility. Excel 
documentation uses the word chart to refer to any kind of graph.  

To generate your chart, first go to the Insert tab. Select the cells that contain the 
results you want to plot, then from the Charts group, click the button for the type of 
chart you require and from the menu select one of the options. 

An instant chart will appear in your spreadsheet, and you will see a new section called 
Chart Tools appear on the ribbon. It contains tabs for Design, Layout and Format. 

In the Design tab you can:  

• change the chart type 
• swap between plotting rows or plotting columns 
• change the colours used in the chart style 
• move the chart to a new location 

In the Layout tab you can: 

• add a title to the chart and to the axes 
• position the chart legend 
• format the chart axes 
• add and  remove gridlines 
• add error bars 

In the Format tab you can: 

• add 3D shading to different areas of the chart 
• change the outline of different areas of the chart 
• add wordart to the chart 

 

The ribbon makes it very easy to create a chart, and very easy to finely tune the chart 
to match your requirements.  
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11. Printing from Excel 
The final task after generating your results and creating a chart is to print out your 
worksheet on a laser printer. If you are only interested in certain extracts from your 
workbook you can copy these to a new worksheet specifically for printing. 

11.1 Print Preview 

Next you can take a look how your worksheet will appear on A4 paper. To do this 
click the Office button, select Print, then from the submenu select Print Preview. 
You will see the Print Preview screen. 

You will see a representation of each page and will be able to get an impression of the 
overall layout. To fine tune your printout, click the Page Setup button. You will see 
a dialog box with four tabs that allow you to change the appearance of your printed 
pages. 

 

If you want to prevent the worksheet gridlines from appearing on your printout click 
on the Sheet tag and remove the check from the Gridlines option in the Print box. 
When you have done this, click on the OK button to return to the preview screen. 

If you like what you see you can now press the Print button, otherwise press the 
Close button and reorganise your worksheet accordingly. 

11.2 Printing 

When the preview looks good you can finally send your worksheet to the printer. 
Either press the Print button from the Preview screen, or click the Office button and 
select the Print option, then from the submenu select Print. 

When you see the dialog box, simply click on the OK button and your sheet will be 
printed on the specified laser printer. 
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12. Putting Excel Objects into Word Documents 
Any data table or chart produced in Excel can be placed in a Word document. 

The easiest way to do this is to select the data or chart in Excel, then click the Copy 
button. Then start Word and place the insertion point wherever you want the Excel 
object to appear. Finally click the Paste button in Word.  

If you had selected a table of data then this will appear in Word as a standard Word 
table, and you can adjust column widths and format cells as usual. If you had selected 
a chart then this will appear in Word as a graphic.  

If you later needed to edit your chart you can simply double click the chart within 
Word. All the Excel menus and toolbars will then be displayed within Word itself and 
you can make any changes as if using Excel. 

This is a very powerful feature which is easy to use; the disadvantage, however, is 
that if you do edit your data or chart in Word, you may end up with two differing 
versions, one in Word, one in Excel. A more elegant way to place Excel objects in a 
Word document is to select and copy the object in Excel, as before, then start Word. 
From the Clipboard group, click the arrow below the Paste button, then from the 
menu select Paste Special to get the following dialog box. 

 

If you now choose the Paste link option then Word will add a link to the Excel 
workbook. This means that whenever you open this Word document it accesses the 
Excel file and loads the data or chart. In this way there is only ever one version of the 
data, and the Excel workbook and Word document will always be consistent with one 
another. 


